Name:           python-NCP-Geolocation
Version:        0.12
Release:        1%{?dist}
Summary:         This is for Geolocation service of Naver Cloud Platfrom  It is simple to use  1. Import and fill your security code ncp_geolocation = NCP_Geolocation_API(oauth_consumer_key="$oauth_consumer_key", secret_key="$secret_key")  2. execute `get_geolocation` function print(ncp_geolocation.get_geolocation("125.209.222.142"))  results : {"returnCode": 0,"requestId": "c2032c47-f678-4de1-b595-461906ea90c4","geoLocation": {"country": "KR","code": "4113558000","r1": "경기도","r2": "성남시 분당구"}} 

# Check if the automatically generated License and its spelling is correct for Fedora
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
License:        Naver Cloud Platform
URL:            https://github.com/ultimatelife/NCP_Geolocation.git
Source0:        %{pypi_source NCP_Geolocation}

BuildArch:      noarch
BuildRequires:  python3-devel


# Fill in the actual package description to submit package to Fedora
%global _description %{expand:
This is package 'ncp-geolocation' generated automatically by pyp2spec.}


%description %_description

%package -n     python3-NCP-Geolocation
Summary:        %{summary}

%description -n python3-NCP-Geolocation %_description


%prep
%autosetup -p1 -n NCP_Geolocation-%{version}


%generate_buildrequires
%pyproject_buildrequires -r


%build
%pyproject_wheel


%install
%pyproject_install
# For official Fedora packages, including files with '*' +auto is not allowed
# Replace it with a list of relevant Python modules/globs and list extra files in %%files
%pyproject_save_files '*' +auto


%check
%pyproject_check_import -t


%files -n python3-NCP-Geolocation -f %{pyproject_files}


%changelog
* Wed Mar 30 2022 mockbuilder - 0.12-1
- Package generated with pyp2spec