Name:           python-dandi
Version:        0.65.1
Release:        %autorelease
# Fill in the actual package summary to submit package to Fedora
Summary:        Command line client for interaction with DANDI archive elements

# No license information obtained, it's up to the packager to fill it in
License:        ...
URL:            http://dandiarchive.org
Source:         %{pypi_source dandi}

BuildArch:      noarch
BuildRequires:  python3-devel


# Fill in the actual package description to submit package to Fedora
%global _description %{expand:
This is package 'dandi' generated automatically by pyp2spec.}

%description %_description

%package -n     python3-dandi
Summary:        %{summary}

%description -n python3-dandi %_description

# For official Fedora packages, review which extras should be actually packaged
# See: https://docs.fedoraproject.org/en-US/packaging-guidelines/Python/#Extras
%pyproject_extras_subpkg -n python3-dandi all,extensions,extras,style,test,tools


%prep
%autosetup -p1 -n dandi-%{version}


%generate_buildrequires
# Keep only those extras which you actually want to package or use during tests
%pyproject_buildrequires -x all,extensions,extras,style,test,tools


%build
%pyproject_wheel


%install
%pyproject_install
# For official Fedora packages, including files with '*' +auto is not allowed
# Replace it with a list of relevant Python modules/globs and list extra files in %%files
%pyproject_save_files '*' +auto


%check
%_pyproject_check_import_allow_no_modules -t


%files -n python3-dandi -f %{pyproject_files}


%changelog
%autochangelog