Summary: A set of basic GNU tools commonly used in shell scripts
Name: coreutils
Version: 9.1
Release: 12%{?dist}
License: GPLv3+
Url: https://www.gnu.org/software/coreutils/
Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
Source1: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz.sig
# From https://savannah.gnu.org/project/release-gpgkeys.php?group=coreutils&download=1
# which is linked as project keyring on https://savannah.gnu.org/projects/coreutils
Source2: coreutils-keyring.gpg
Source50: supported_utils
Source51: coreutils-provides.inc
Source105: coreutils-colorls.sh
Source106: coreutils-colorls.csh
# do not make coreutils-single depend on /usr/bin/coreutils
%global __requires_exclude ^%{_bindir}/coreutils$
# Make simple backups in correct dir; broken in 9.1
Patch1: gnulib-simple-backup-fix.patch
# basic support for checking NFSv4 ACLs (#2137866)
Patch2: coreutils-nfsv4-acls.patch
# Fix directory-relative syscalls in copy code; broken in 9.1
Patch3: coreutils-9.1-copy-relative-dir.patch
# disable the test-lock gnulib test prone to deadlock
Patch100: coreutils-8.26-test-lock.patch
# require_selinux_(): use selinuxenabled(8) if available
Patch101: coreutils-8.26-selinuxenable.patch
# downstream changes to default DIR_COLORS
Patch102: coreutils-8.32-DIR_COLORS.patch
# df --direct
Patch104: coreutils-df-direct.patch
# (sb) lin18nux/lsb compliance - multibyte functionality patch
Patch800: coreutils-i18n.patch
# getgrouplist() patch from Ulrich Drepper.
Patch908: coreutils-getgrouplist.patch
# downstream SELinux options deprecated since 2009
Patch950: coreutils-selinux.patch
Conflicts: filesystem < 3
# To avoid clobbering installs
Conflicts: coreutils-single
BuildRequires: attr
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc
BuildRequires: gettext-devel
BuildRequires: gmp-devel
BuildRequires: hostname
BuildRequires: libacl-devel
BuildRequires: libattr-devel
BuildRequires: libcap-devel
BuildRequires: libselinux-devel
BuildRequires: libselinux-utils
BuildRequires: make
BuildRequires: openssl-devel
BuildRequires: strace
BuildRequires: texinfo
# For gpg verification of source tarball
BuildRequires: gnupg2
# test-only dependencies
BuildRequires: perl-interpreter
BuildRequires: perl(FileHandle)
%if 23 < 0%{?fedora} || 7 < 0%{?rhel}
# needed by i18n test-cases
BuildRequires: glibc-langpack-en
BuildRequires: glibc-langpack-fr
BuildRequires: glibc-langpack-ko
%endif
Requires: %{name}-common = %{version}-%{release}
Provides: coreutils-full = %{version}-%{release}
%include %{SOURCE51}
Obsoletes: %{name} < 8.24-100
%description
These are the GNU core utilities. This package is the combination of
the old GNU fileutils, sh-utils, and textutils packages.
%package single
Summary: coreutils multicall binary
Suggests: coreutils-common
Provides: coreutils = %{version}-%{release}
Provides: coreutils%{?_isa} = %{version}-%{release}
%include %{SOURCE51}
# To avoid clobbering installs
Conflicts: coreutils < 8.24-100
# Note RPM doesn't support separate buildroots for %files
# http://rpm.org/ticket/874 so use RemovePathPostfixes
# (new in rpm 4.13) to support separate file sets.
RemovePathPostfixes: .single
%description single
These are the GNU core utilities,
packaged as a single multicall binary.
%package common
# yum obsoleting rules explained at:
# https://bugzilla.redhat.com/show_bug.cgi?id=1107973#c7
Obsoletes: %{name} < 8.24-100
# info doc refers to "Specifying the Time Zone" from glibc-doc (#959597)
Suggests: glibc-doc
Summary: coreutils common optional components
%description common
Optional though recommended components,
including documentation and translations.
%prep
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
%autosetup -N
# will be regenerated in the build directories
rm -f src/fs.h
# will be further modified by coreutils-8.32-DIR_COLORS.patch
sed src/dircolors.hin \
-e 's| 00;36$| 01;36|' \
> DIR_COLORS
sed src/dircolors.hin \
-e 's| 01;31$| 00;31|' \
-e 's| 01;35$| 00;35|' \
> DIR_COLORS.lightbgcolor
# git add DIR_COLORS{,.lightbgcolor}
# git commit -m "clone DIR_COLORS before patching"
# apply all patches
%autopatch -p1
(echo ">>> Fixing permissions on tests") 2>/dev/null
find tests -name '*.sh' -perm 0644 -print -exec chmod 0755 '{}' '+'
(echo "<<< done") 2>/dev/null
autoreconf -fiv
%build
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
# disable -flto on ppc64le to make test-float pass (#1789115)
%ifarch ppc64le
CFLAGS="$CFLAGS -fno-lto"
%endif
# Upstream suggests to build with -Dlint for static analyzers:
# https://lists.gnu.org/archive/html/coreutils/2018-06/msg00110.html
# ... and even for production binary RPMs:
# https://lists.gnu.org/archive/html/bug-gnulib/2020-05/msg00130.html
# There is currently no measurable performance drop or other known downside.
CFLAGS="$CFLAGS -Dlint"
# make mknod work again in chroot without /proc being mounted (#1811038)
export ac_cv_func_lchmod="no"
# needed for out-of-tree build
%global _configure ../configure
%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
for type in separate single; do
mkdir -p $type && \
(cd $type || exit $?
if test $type = 'single'; then
config_single='--enable-single-binary'
config_single="$config_single --without-openssl" # smaller/slower sha*sum
config_single="$config_single --without-libgmp" # expr/factor machine ints
else
config_single='--with-openssl' # faster sha*sum
fi
%configure $config_single \
--cache-file=../config.cache \
--enable-install-program=arch \
--enable-no-install-program=kill,uptime \
--with-tty-group \
DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
%make_build all V=1
# make sure that parse-datetime.{c,y} ends up in debuginfo (#1555079)
ln -fv ../lib/parse-datetime.{c,y} .
)
done
# Get the list of supported utilities
cp %SOURCE50 .
%check
for type in separate single; do
test $type = 'single' && subdirs='SUBDIRS=.' # Only check gnulib once
(cd $type && make check %{?_smp_mflags} $subdirs)
done
%install
for type in separate single; do
install=install
if test $type = 'single'; then
subdir=%{_libexecdir}/%{name}; install=install-exec
fi
(cd $type && make DESTDIR=$RPM_BUILD_ROOT/$subdir $install)
# chroot was in /usr/sbin :
mkdir -p $RPM_BUILD_ROOT/$subdir/{%{_bindir},%{_sbindir}}
mv $RPM_BUILD_ROOT/$subdir/{%_bindir,%_sbindir}/chroot
# Move multicall variants to *.single.
# RemovePathPostfixes will strip that later.
if test $type = 'single'; then
for dir in %{_bindir} %{_sbindir} %{_libexecdir}/%{name}; do
for bin in $RPM_BUILD_ROOT/%{_libexecdir}/%{name}/$dir/*; do
basebin=$(basename $bin)
mv $bin $RPM_BUILD_ROOT/$dir/$basebin.single
done
done
fi
done
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
install -p -c -m644 DIR_COLORS{,.lightbgcolor} $RPM_BUILD_ROOT%{_sysconfdir}
install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
%find_lang %name
# Add the %%lang(xyz) ownership for the LC_TIME dirs as well...
grep LC_TIME %name.lang | cut -d'/' -f1-6 | sed -e 's/) /) %%dir /g' >>%name.lang
# (sb) Deal with Installed (but unpackaged) file(s) found
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
%files -f supported_utils
%exclude %{_bindir}/*.single
%dir %{_libexecdir}/coreutils
%{_libexecdir}/coreutils/*.so
%files single
%{_bindir}/*.single
%{_sbindir}/chroot.single
%dir %{_libexecdir}/coreutils
%{_libexecdir}/coreutils/*.so.single
# duplicate the license because coreutils-common does not need to be installed
%{!?_licensedir:%global license %%doc}
%license COPYING
%files common -f %{name}.lang
%config(noreplace) %{_sysconfdir}/DIR_COLORS*
%config(noreplace) %{_sysconfdir}/profile.d/*
%{_infodir}/coreutils*
%{_mandir}/man*/*
# The following go to /usr/share/doc/coreutils-common
%doc ABOUT-NLS NEWS README THANKS TODO
%license COPYING
%changelog
* Thu May 04 2023 Pádraig Brady
- 9.1-12
- further fixes to backups; broken in 9.1
- fix some directory-relative syscalls; broken in 9.1
* Thu Jan 19 2023 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Mon Jan 02 2023 Kamil Dudka - 9.1-10
- drop obsolete downstream-only extension of date(1) man page
- undocument downstream SELinux options deprecated since 2009
* Mon Jan 02 2023 Kamil Dudka - 9.1-9
- basic support for checking NFSv4 ACLs (#2137866)
* Mon Sep 19 2022 Kamil Dudka - 9.1-8
- remove obsolete extension of mkdir(1) info documentation
* Tue Aug 23 2022 Kamil Dudka - 9.1-7
- remove non-upstream patch for uname -i/-p (#548834)
* Mon Aug 08 2022 Kamil Dudka - 9.1-6
- improve wording of a comment in /etc/DIR_COLORS (#2112593)
* Mon Aug 08 2022 Kamil Dudka - 9.1-5
- improve handling of control characters in unexpand (#2112870)
* Mon Aug 01 2022 Kamil Dudka - 9.1-4
- prevent unexpand from failing on control characters (#2112870)
* Wed Jul 20 2022 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Sat Apr 23 2022 Pádraig Brady - 9.1-2
- make simple backups in correct dir; broken in 9.1
* Tue Apr 19 2022 Kamil Dudka - 9.1-1
- new upstream release 9.1
* Mon Mar 21 2022 Kamil Dudka - 9.0-5
- ls, stat: avoid triggering automounts (#2044981)
* Tue Mar 01 2022 Kamil Dudka - 9.0-4
- make `df --direct` work again (#2058686)
* Wed Jan 19 2022 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Mon Oct 04 2021 Kamil Dudka - 9.0-2
- chmod: fix exit status when ignoring symlinks
* Sun Sep 26 2021 Kamil Dudka - 9.0-1
- new upstream release 9.0
* Tue Sep 14 2021 Sahana Prasad
- Rebuilt with OpenSSL 3.0.0
* Wed Jul 21 2021 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jul 07 2021 Kamil Dudka - 8.32-30
- df: fix duplicated remote entries due to bind mounts (#1979814)
* Thu Jul 01 2021 Kamil Dudka - 8.32-28
- tail: fix stack out-of-bounds write with --follow
* Tue Jun 08 2021 Kamil Dudka - 8.32-27
- mountlist: recognize fuse.portal as dummy file system (#1913358)
* Mon May 17 2021 Kamil Dudka - 8.32-26
- cp: pick additional copy_file_range()-related fixes from upstream
* Mon May 03 2021 Kamil Dudka - 8.32-24
- copy: ensure we enforce --reflink=never (#1956080)
* Tue Apr 27 2021 Kamil Dudka - 8.32-23
- copy: do not refuse to copy a swap file
* Fri Apr 09 2021 Kamil Dudka - 8.32-22
- weaken the dependency on glibc-doc to reduce minimal installations
- drop the last use of ncurses no longer needed (#1830318)
- utimens: fix confusing arg type in internal func
* Fri Mar 26 2021 Kamil Dudka - 8.32-21
- hostname,ln: fix memory leaks detected by Coverity
* Wed Mar 24 2021 Kamil Dudka - 8.32-20
- cp: use copy_file_range if available
* Thu Feb 18 2021 Kamil Dudka - 8.32-19
- stat: add support for the exfat file system (#1921427)
* Wed Feb 03 2021 Kamil Dudka - 8.32-18
- make coreutils-common recommend glibc-doc for info doc refs (#959597)
* Tue Feb 02 2021 Kamil Dudka - 8.32-17
- ls: fix crash printing SELinux context for unstatable files (#1921249)
- split: fix --number=K/N to output correct part of file (#1921246)
- expr: fix invalid read with unmatched \(...\) (#1919775)
* Tue Jan 26 2021 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Tue Dec 08 2020 Kamil Dudka - 8.32-15
- rm: do not skip files upon failure to remove an empty dir (#1905481)
* Tue Nov 03 2020 Kamil Dudka - 8.32-14
- df,stat,tail: recognize more file system types
* Wed Oct 14 2020 Kamil Dudka - 8.32-13
- make the %%build section idempotent
* Mon Aug 17 2020 Kamil Dudka - 8.32-12
- do not install /etc/DIR_COLORS.256color (#1830318)
* Thu Jul 30 2020 Kamil Dudka - 8.32-11
- cp: default to --reflink=auto (#1861108)
* Mon Jul 27 2020 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jul 24 2020 Kamil Dudka - 8.32-9
- disable -flto on ppc64le to make test-float pass (#1789115)
* Mon Jul 13 2020 Tom Stellard - 8.32-8
- Use make macros
- https://fedoraproject.org/wiki/Changes/UseMakeBuildInstallMacro
* Fri Jun 26 2020 James Cassell - 8.32-7
- move ncurses to -common package since it's needed for colorls.sh
- make ncurses optional
* Fri May 15 2020 Kamil Dudka - 8.32-6
- compile with -Dlint to enable optional initialization and cleanup code
* Thu Apr 23 2020 Kamil Dudka - 8.32-5
- du: simplify leaf optimization for XFS (#1823247)
* Fri Apr 17 2020 Tom Stellard - 8.32-4
- Fix missing inline function definition
* Wed Mar 11 2020 Kamil Dudka - 8.32-3
- uniq: remove collation handling as required by newer POSIX
* Mon Mar 09 2020 Kamil Dudka - 8.32-2
- make mknod work again in chroot without /proc being mounted (#1811038)
- ls: restore 8.31 behavior on removed directories
* Thu Mar 05 2020 Kamil Dudka - 8.32-1
- new upstream release 8.32
* Tue Feb 11 2020 Kamil Dudka - 8.31-10
- make upstream test-suite work with root privileges (#1800597)
* Wed Feb 05 2020 Kamil Dudka - 8.31-9
- use upstream fix the cp/proc-short-read test
* Thu Jan 30 2020 Kamil Dudka - 8.31-8
- skip a test that relies on /proc/kallsyms having immutable content
* Tue Jan 28 2020 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Thu Oct 17 2019 Kamil Dudka - 8.31-6
- temporarily disable the use of statx (#1760300)
* Fri Oct 11 2019 Kamil Dudka - 8.31-5
- use statx instead of stat when available (#1760300)
* Wed Jul 24 2019 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Tue Jul 16 2019 Kamil Dudka - 8.31-3
- disable flashing in ls colors for broken symbolic links (#1728986)
* Mon Mar 18 2019 Kamil Dudka - 8.31-2
- fix formatting of sha512sum(1) man page (#1688740)
* Mon Mar 11 2019 Kamil Dudka - 8.31-1
- new upstream release 8.31
* Thu Jan 31 2019 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Wed Nov 07 2018 Kamil Dudka - 8.30-8
- sync: fix open() fallback bug
- fix implicit declaration warning in coreutils-getgrouplist.patch
* Sat Nov 03 2018 Kevin Fenzi - 8.30-7
- Also remove Requires pre/post used by info scriptlets.
* Sat Nov 03 2018 Kevin Fenzi - 8.30-6
- Remove no longer needed info scriptlets
* Thu Oct 11 2018 Kamil Dudka - 8.30-5
- fix heap-based buffer overflow in vasnprintf() (CVE-2018-17942)
* Thu Jul 12 2018 Fedora Release Engineering - 8.30-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jul 10 2018 Kamil Dudka - 8.30-3
- rename gnulib's renameat2 to renameatu to avoid clash with glibc (#1598518)
* Wed Jul 04 2018 Kamil Dudka - 8.30-2
- sync i18n patches with Suse (patch by Bernhard Voelker)
* Mon Jul 02 2018 Kamil Dudka - 8.30-1
- new upstream release 8.30
* Wed May 30 2018 Kamil Dudka - 8.29-12
- add provides to coreutils-single to make it a drop-in replacement
* Mon May 28 2018 Kamil Dudka - 8.29-11
- ls: increase the allowed abmon width from 5 to 12 (#1577872)
- date, ls: pick strftime fixes from glibc to improve locale support (#1577872)
* Fri Apr 20 2018 Kamil Dudka - 8.29-10
- fix crash caused by mistakenly enabled leaf optimization (#1558249)
* Fri Mar 23 2018 Kamil Dudka - 8.29-9
- make it possible to install the latest available Adobe Reader RPM for Linux
* Mon Mar 19 2018 Kamil Dudka - 8.29-8
- drop BR for bison, which is not used during the build
* Fri Mar 16 2018 Kamil Dudka - 8.29-7
- make sure that parse-datetime.{c,y} ends up in debuginfo (#1555079)
* Tue Mar 06 2018 Kamil Dudka - 8.29-6
- fix build failure with glibc-2.28
* Mon Feb 26 2018 Igor Gnatenko - 8.29-5
- Remove /bin/* Provides
* Mon Feb 19 2018 Kamil Dudka - 8.29-4
- add explicit BR for the gcc compiler
* Wed Feb 07 2018 Fedora Release Engineering - 8.29-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Tue Jan 23 2018 Kamil Dudka - 8.29-2
- doc: warn about following symlinks recursively in chown/chgrp (CVE-2017-18018)
- mv -n: do not overwrite the destination
* Tue Jan 02 2018 Kamil Dudka - 8.29-1
- new upstream release 8.29
* Tue Nov 07 2017 Igor Gnatenko - 8.28-2
- Remove very old Provides (mktemp, sh-utils, textwrap, fileutils, stat)
* Mon Sep 04 2017 Kamil Dudka - 8.28-1
- new upstream release 8.28
* Tue Aug 22 2017 Ville Skyttä - 8.27-16
- Own the %%{_libexecdir}/coreutils dir
* Fri Aug 18 2017 Kamil Dudka - 8.27-15
- ptx: fix a possible crash caused by integer overflow (#1482445)
* Wed Aug 02 2017 Fedora Release Engineering - 8.27-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Fri Jul 28 2017 Igor Gnatenko - 8.27-13
- Enable separate debuginfo back
* Wed Jul 26 2017 Kamil Dudka - 8.27-12
- avoid build failure caused broken RPM code that produces debuginfo packages
* Wed Jul 26 2017 Fedora Release Engineering - 8.27-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Tue May 30 2017 Sebastian Kisela - 8.27-10
- doc: mention `setpriv --no-new-privs` feature in runcon info
* Tue May 16 2017 Kamil Dudka - 8.27-9
- add coreutils-full provides for coreutils to make it explicitly installable
* Wed May 03 2017 Kamil Dudka - 8.27-8
- drop coreutils-overflow.patch no longer needed (#158405)
* Wed May 03 2017 Kamil Dudka - 8.27-7
- drop workaround for already fixed rpm-build bug (#1306559)
* Wed May 03 2017 Kamil Dudka - 8.27-6
- do not mention a deprecated option in localized man pages
- drop workaround no longer needed for 10 years old rpm-build bug (#246729)
- drop unnecessary uses of %%defattr
* Fri Apr 28 2017 Sebastian Kisela - 8.27-5
- tail: revert to polling if a followed directory is replaced (#1283760)
* Thu Apr 27 2017 Kamil Dudka - 8.27-4
- date, touch: fix out-of-bounds write via large TZ variable (CVE-2017-7476)
* Tue Apr 25 2017 Kamil Dudka - 8.27-3
- do not obsolete coreutils-single, so it can be installed by DNF2 (#1444802)
* Wed Mar 15 2017 Kamil Dudka - 8.27-2
- fix spurious build failure caused by the misc/date-debug test
* Thu Mar 09 2017 Kamil Dudka - 8.27-1
- new upstream release 8.27
* Fri Feb 10 2017 Fedora Release Engineering - 8.26-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Feb 03 2017 Kamil Dudka - 8.26-6
- fold: preserve new-lines in mutlibyte text (#1418505)
* Mon Jan 23 2017 Kamil Dudka - 8.26-5
- date: fix TZ= regression (patch by Pádraig Brady)
* Mon Jan 02 2017 Kamil Dudka - 8.26-4
- use upstream patch for gnulib's test-lock (instead of disabling it)
* Thu Dec 15 2016 Kamil Dudka - 8.26-3
- drop build fixes no longer needed
* Fri Dec 02 2016 Kamil Dudka - 8.26-2
- apply patches automatically to ease maintenance
* Thu Dec 01 2016 Kamil Dudka - 8.26-1
- new upstream release 8.26
* Mon Oct 31 2016 Kamil Dudka - 8.25-17
- md5sum,sha*sum: fix --ignore-missing with checksums starting with 00
* Tue Oct 11 2016 Tomáš Mráz - 8.25-16
- rebuild with OpenSSL 1.1.0
* Wed Sep 07 2016 Kamil Dudka - 8.25-15
- ls: allow interruption when reading slow directories (#1365933)
* Tue Jul 19 2016 Kamil Dudka - 8.25-14
- run autoreconf in %%prep
- drop post-install fix for Japanese locales that no longer applies
- fix 'sort -h -k' in locales that use blank as thousands separator (#1355780)
* Thu Jul 14 2016 Kamil Dudka - 8.25-13
- make 'sort -h' work for arbitrary column even when using UTF-8 locales
* Mon Jul 11 2016 Kamil Dudka - 8.25-12
- install -Z now sets default SELinux context for created directories (#1339135)
- drop the %%pre scriptlet, which is no longer needed (#1354078)
- clarify recognition of "^COLOR.*none" in /etc/DIR_COLORS (#1349579)
* Thu Jul 07 2016 Jakub Martisko - 8.25-11
- switch to UTF8 locale when (un)expand input contains BOM header
(#1158494)
- fixed regression where (un)expand would end with "long input line"
error when BOM header is present
* Fri Jun 24 2016 Ondrej Vasik - 8.25-10
- change way of detection of interactive shell in colorls.sh script
(#1321648)
* Mon Jun 20 2016 Kamil Dudka - 8.25-9
- add BR for glibc-langpack-en to prevent the expand/mb test from failing
- do not use /bin/mv in %%post to avoid a circular dependency (#1348043)
* Fri Jun 17 2016 Kamil Dudka - 8.25-8
- sync /etc/DIR_COLORS with latest upstream (#1335320)
* Wed Jun 15 2016 Kamil Dudka - 8.25-7
- handle info doc in RPM scriptlets of coreutils-common, which provides it
- make sure that the license file is installed, even if coreutils-common is not
* Thu Jun 09 2016 Jakub Martisko - 8.25-6
- (un)expand: fix regression in handling input files, where only
the first file was processed.
* Sat Mar 05 2016 Ondrej Vasik - 8.25-5
- cut: move back to the old i18n implementation (#1314722)
* Mon Feb 15 2016 Ondrej Vasik - 8.25-4
- cut: fix regression in handling fields for lines wider
than 64 chars (#1304839)
* Thu Feb 11 2016 Lubomir Rintel - 8.25-3
- Fix a regression in unexpand empty line handling
* Thu Jan 21 2016 Ondrej Vasik - 8.25-2
- Adjust the i18n patch for coreutils-8.25
- add new base32 binary
* Wed Jan 20 2016 Ondrej Vasik - 8.25-1
- new upstream release(#1300282)
* Fri Jan 15 2016 Ondrej Oprala - 8.24-108
- cut: be MB for ALL archs
* Fri Jan 15 2016 Ondrej Oprala - 8.24-107
- Use the new i18n implementation for the cut utility
* Wed Jan 13 2016 Ondrej Vasik - 8.24-106
- mv: prevent dataloss when source dir is specified multiple
times (#1297464, by P.Brady)
* Mon Dec 14 2015 Pádraig Brady - 8.24-105
- Give explicit priority to coreutils over coreutils-single
* Thu Dec 03 2015 Pádraig Brady - 8.24-104
- Avoid libgmp and libcrypto dependencies from coreutils-single
* Thu Dec 03 2015 Pádraig Brady - 8.24-103
- Remove erroneous /usr/bin/kill from coreutils-single
* Tue Dec 01 2015 Ondrej Oprala - 8.24-102
- Use the new i18n implementation for expand/unexpand
* Mon Nov 30 2015 Ondrej Vasik - 8.24-101
- coreutils-single should provide versioned coreutils (#1286338)
* Wed Nov 18 2015 Pádraig Brady - 8.24-100
- Split package to more easily support smaller installs
* Wed Sep 16 2015 Kamil Dudka - 8.24-4
- fix memory leak in sort/I18N (patches written by Pádraig, #1259942)
* Sat Sep 12 2015 Ondrej Vasik 8.24-3
- fix one still existing occurance of non-full path in colorls.sh
* Thu Jul 16 2015 Ondrej Vasik 8.24-2
- use newer version of sort/I18N fix for CVE-2015-4041
and CVE-2015-4042
* Sun Jul 05 2015 Ondrej Vasik 8.24-1
- new upstream release 8.24
* Sat Jul 4 2015 Peter Robinson 8.23-14
- Disable failing test-update-copyright to fix FTBFS
* Wed Jun 17 2015 Fedora Release Engineering - 8.23-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Thu Jun 04 2015 Ondrej Vasik - 8.23-12
- call utilities in colorls.* scripts with full path (#1222140)
* Thu May 14 2015 Kamil Dudka - 8.23-11
- run 'make check' in parallel to speed up the build
* Wed May 13 2015 Ondrej Oprala - 8.23-10
- sort - fix buffer overflow in some case conversions
- patch by Pádraig Brady
* Mon Apr 20 2015 Pádraig Brady - 8.23-9
- Adjust LS_COLORS in 256 color mode; brighten some, remove hardlink colors (#1196642)
* Sun Mar 22 2015 Peter Robinson 8.23-8
- Drop large ancient docs
* Sat Feb 21 2015 Till Maas - 8.23-7
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
* Mon Dec 01 2014 Ondrej Vasik - 8.23-6
- have the LC_TIME subdirs with lang macro (#1169027)
* Wed Oct 15 2014 Ondrej Vasik - 8.23-5
- handle situation with ro /tmp in colorls scripts (#1149761)
* Wed Oct 01 2014 Ondrej Vasik - 8.23-4
- fix the sorting in multibyte locales (NUL-terminate sort keys)
- patch by Andreas Schwab (#1146185)
* Sat Aug 16 2014 Fedora Release Engineering - 8.23-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Tue Aug 05 2014 Ondrej Vasik - 8.23-2
- enable smp_flags again (by B.Voelker)
- fix regression in chroot
* Tue Jul 22 2014 Ondrej Vasik - 8.23-1
- new upstream release 8.23
- synchronize the old differences in ls SELinux options
with upstream
- skip df/skip-duplicates.sh test for now (passing locally, failing in koji)
* Fri Jul 11 2014 Tom Callaway - 8.22-17
- fix license handling
* Mon Jun 23 2014 Jakub Čajka - 8.22-16
- fix failed tests on ppc(backport from gnulib upstream)
* Sat Jun 07 2014 Fedora Release Engineering - 8.22-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sat Apr 12 2014 Ondrej Vasik 8.22-14
- fix dd sparse test failure on xfs filesystem(#1085727,
by P.Brady)
* Wed Mar 05 2014 Ondrej Vasik 8.22-13
- drop the util-linux requirements (smaller docker images),
drop ancient obsoletes of -libs subpackage
* Sun Mar 02 2014 Ondrej Vasik 8.22-12
- fix the date crash or infloop in TZ="" parsing (#1069657)
* Mon Jan 13 2014 Ondrej Vasik 8.22-11
- cp/mv/install: do not crash when getfscreatecon() is
returning a NULL context
* Mon Jan 13 2014 Ondrej Vasik 8.22-10
- unset the unnecessary envvars after colorls scripts(#1051703)
- improve the limitation (check for both utf8 and utf-8)
* Fri Jan 10 2014 Ondrej Oprala 8.22-9
- Limit the cut optimizations to UTF-8 locales only
* Wed Jan 08 2014 Ondrej Oprala 8.22-8
- Don't use cut mb path if not necessary (#1021403, #499220)
- several i18n patch improvements merged from OpenSUSE (fixed
compilation warnings, simplify mb handling in uniq)
* Mon Jan 06 2014 Ondrej Oprala 8.22-7
- Fix sorting by non-first field (#1003544)
* Fri Jan 03 2014 Ondrej Vasik 8.22-6
- do not modify SELinux contexts of existing parent
directories when copying files (fix by P.Brady, #1045122)
* Thu Jan 02 2014 Ondrej Oprala 8.22-5
- reverted an old change and constricted it's condition
- turned off two multibyte tests (wrong strcoll return value)
* Mon Dec 23 2013 Ondrej Vasik 8.22-4
- skip even the ls aliases in noninteractive mode
(suggested by T. Cordes, #988152)
* Sun Dec 22 2013 Ondrej Vasik 8.22-3
- reset buffer before copying to prevent some rare cases of
invalid output in join and uniq(#1036289)
* Sat Dec 14 2013 Ondrej Vasik 8.22-1
- new upstream version 8.22
- temporarily disable multibyte cut.pl part and df symlink
tests
* Thu Dec 12 2013 Ondrej Vasik 8.21-23
- skip output-is-input-mb.p test - failing on armv7l (reported
by B.Voelker)
* Mon Dec 9 2013 Peter Robinson 8.21-22
- Add upstream patch to fix test failures on aarch64
* Thu Nov 28 2013 Ondrej Vasik 8.21-21
- turn on the multibyte path in the testsuite to cover
i18n regressions
* Wed Nov 06 2013 Ondrej Vasik 8.21-20
- fix possible colorls.csh script errors for tcsh with
noclobber set and entered include file (#1027279)
* Mon Oct 14 2013 Ondrej Vasik 8.21-19
- cp: correct error message for invalid arguments
of '--no-preserve' (#1018206)
* Thu Aug 15 2013 Ondrej Vasik 8.21-18
- pr -e, with a mix of backspaces and TABs, could corrupt the heap
in multibyte locales (analyzed by J.Koncicky)
* Wed Aug 14 2013 Ondrej Oprala 8.21-17
- Fix sort multibyte incompatibilities
* Sat Aug 03 2013 Fedora Release Engineering - 8.21-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Wed Jul 17 2013 Ondrej Oprala 8.21-15
- change the TMP variable name in colorls.csh to _tmp (#981373)
* Fri May 17 2013 Ondrej Vasik 8.21-10
- DIR_COLORS.$TERM should have higher priority than
DIR_COLORS.256color (#921651)
* Mon Mar 11 2013 Ondrej Oprala 8.21-9
- add support for INCLUDE in colorls scripts (#818069)
* Mon Mar 04 2013 Ondrej Vasik 8.21-8
- fix factor on AArch64 (M.Salter, #917735)
* Fri Mar 01 2013 Ondrej Vasik 8.21-7
- ls: colorize several new archive/compressed types (#868510)
* Sat Feb 23 2013 Ondrej Vasik 8.21-6
- install: do proper cleanup when strip fails
(O.Oprala, B.Voekler, #632444)
* Wed Feb 20 2013 Ondrej Vasik 8.21-5
- fix multibyte issue in unexpand(by R.Kollar, #821262)
* Mon Feb 18 2013 Ondrej Oprala 8.21-4
- fix sort-mb-tests.sh test (B.Voelker)
* Mon Feb 18 2013 Mark Wielaard 8.21-3
- fix coreutils-i18n.patch to terminate mbdelim string (#911929)
* Mon Feb 18 2013 Ondrej Vasik 8.21-2
- remove unnecessary powerpc factor patch
* Fri Feb 15 2013 Ondrej Vasik 8.21-1
- new upstream release 8.21, update patches
* Thu Feb 07 2013 Ondrej Oprala 8.20-8
- add missing sort-mb-tests.sh to local.mk
* Tue Feb 05 2013 Ondrej Vasik 8.20-7
- add support for DTR/DSR control flow in stty(#445213)
* Wed Jan 23 2013 Ondrej Vasik 8.20-6
- fix multiple segmantation faults in i18n patch (by SUSE)
(#869442, #902917)
* Thu Dec 20 2012 Ondrej Vasik 8.20-5
- seq: fix newline output when -s specified (upstream)
* Mon Dec 10 2012 Ondrej Vasik 8.20-4
- fix showing duplicates in df (#709351, O.Oprala, B.Voelker)
* Thu Dec 06 2012 Ondrej Vasik 8.20-3
- fix factor on 32bit powerpc (upstream, #884715)
* Mon Nov 05 2012 Ondrej Vasik 8.20-2
- disable the temporary O_SYNC fix (glibc is fixed - #872366)
* Sat Oct 27 2012 Ondrej Vasik 8.20-1
- new upstream release 8.20
- Temporarily require util-linux >= 2.22.1-3 (to prevent missing
su/runuser on system)
* Mon Aug 20 2012 Ondrej Vasik 8.19-1
- new upstream release 8.19
- fix multibyte issues in cut and expand (M.Briza, #821260)
* Sun Aug 12 2012 Ondrej Vasik 8.18-1
- new upstream release 8.18
- su/runuser moved to util-linux
* Wed Jul 18 2012 Fedora Release Engineering - 8.17-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Tue May 15 2012 Ondrej Vasik 8.17-3
- add virtual provides for bundled(gnulib) copylib (#821748)
* Fri May 11 2012 Ondrej Vasik 8.17-2
- ls: upstream fix - correctly show symlinks in /
* Fri May 11 2012 Ondrej Vasik 8.17-1
- new upstream release 8.17
* Fri May 04 2012 Ondrej Vasik 8.16-3
- add .htm and .shtml to colorized DIR_COLORS document
type (#817218)
* Mon Apr 16 2012 Ondrej Vasik 8.16-2
- fix the tcsh colorls.csh behaviour in non-interactive
mode (#804604)
* Mon Mar 26 2012 Ondrej Vasik 8.16-1
- new upstream release 8.16
- defuzz patches, remove already applied patches
* Thu Mar 08 2012 Ondrej Vasik 8.15-8
- fix regression in du -x with nondir argument (by J.Meyering)
* Wed Mar 07 2012 Ondrej Vasik 8.15-7
- fix sort segfault with multibyte locales (by P.Brady)
* Fri Feb 10 2012 Harald Hoyer 8.15-6
- turn on testsuite again
* Wed Jan 25 2012 Harald Hoyer 8.15-5
- add filesystem guard
* Wed Jan 25 2012 Harald Hoyer 8.15-4
- add missing provides for the /usr-move
* Wed Jan 25 2012 Harald Hoyer 8.15-3
- install everything in /usr
https://fedoraproject.org/wiki/Features/UsrMove
* Mon Jan 16 2012 Kamil Dudka - 8.15-2
- fix stack smashing, buffer overflow, and invalid output of pr (#772172)
* Sat Jan 07 2012 Ondrej Vasik - 8.15-1
- new upstream release 8.15
* Thu Jan 05 2012 Ondrej Vasik - 8.14-6
- do not use shebang in sourced colorls.csh
* Thu Jan 05 2012 Ondrej Vasik - 8.14-5
- fix pr -c and pr -v segfault with multibyte locales
* Mon Oct 31 2011 Rex Dieter 8.14-4
- rebuild (gmp), last time, I promise
* Mon Oct 24 2011 Ondrej Vasik - 8.14-3
- require at least pam 1.1.3-7 (#748215)
* Thu Oct 20 2011 Ondrej Vasik - 8.14-2
- rebuild for gmp
* Wed Oct 12 2011 Ondrej Vasik - 8.14-1
- new upstream release 8.14
* Mon Sep 26 2011 Peter Schiffer - 8.13-2.2
- rebuild with new gmp
* Mon Sep 12 2011 Ondrej Vasik - 8.13-2
- Obsolete coreutils-libs (#737287)
* Fri Sep 09 2011 Ondrej Vasik - 8.13-1
- new upstream release 8.13
- temporarily disable recently added multibyte checks in
misc/cut test
- fix the SUSE fix for cut output-delimiter
- drop coreutils-libs subpackage, no longer needed
* Mon Sep 05 2011 Ondrej Vasik - 8.12-7
- incorporate some i18n patch fixes from OpenSUSE:
- fix cut output-delimiter option
- prevent infinite loop in sort when ignoring chars
- prevent using unitialized variable in cut
* Tue Aug 23 2011 Ondrej Vasik - 8.12-6
- su: fix shell suspend in tcsh (#597928)
* Thu Aug 18 2011 Ondrej Vasik - 8.12-5
- variable "u" should be static in uname processor type patch
* Thu Aug 11 2011 Ondrej Vasik - 8.12-4
- deprecate non-upstream cp -Z/--context (install should be
used instead of it), make it working if destination exists
(#715557)
* Fri Jul 29 2011 Ondrej Vasik - 8.12-3
- use acl_extended_file_nofollow() if available (#692823)
* Fri Jul 15 2011 Ondrej Vasik - 8.12-2
- support ecryptfs mount of Private (postlogin into su.pamd)
(#722323)
* Wed Apr 27 2011 Ondrej Vasik - 8.12-1
- new upstream release 8.12
* Thu Apr 14 2011 Ondrej Vasik - 8.11-2
- fix issue with df --direct(extra new line)
* Thu Apr 14 2011 Ondrej Vasik - 8.11-1
- new upstream release 8.11, defuzz patches
* Tue Mar 22 2011 Ondrej Vasik - 8.10-7
- add note about mkdir mode behaviour into info
documentation (#610559)
* Mon Mar 14 2011 Ondrej Vasik - 8.10-6
- fix possible uninitalized variables usage caused by i18n
patch(#683799)
* Fri Mar 4 2011 Ondrej Vasik - 8.10-5
- make coreutils build even without patches (with
nopam, norunuser and noselinux variables)
* Thu Feb 17 2011 Ondrej Vasik - 8.10-4
- colorize documents by DIR_COLORS files(brown like mc)
* Thu Feb 17 2011 Ondrej Vasik - 8.10-3
- add several new TERMs to DIR_COLORS files(#678147)
* Tue Feb 08 2011 Fedora Release Engineering - 8.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Fri Feb 04 2011 Ondrej Vasik - 8.10-1
- new upstream release coreutils-8.10
* Sat Jan 08 2011 Dennis Gilmore - 8.9-2
- drop no longer needed mkstemp patch for sparc
* Tue Jan 04 2011 Ondrej Vasik - 8.9-1
- new upstream release coreutils-8.9
* Fri Dec 31 2010 Ondrej Vasik - 8.8-2
- The suffix length was dependent on the number of bytes
or lines per file (#666293)
* Thu Dec 23 2010 Ondrej Vasik - 8.8-1
- fix parallel sorting issue (#655096)
- new upstream release coreutils-8.8 (#665164)
* Thu Nov 18 2010 Ondrej Vasik - 8.7-2
- don't prompt for password with runuser(#654367)
* Mon Nov 15 2010 Ondrej Vasik - 8.7-1
- new upstream release coreutils-8.7
- pam support in su consolidation with SUSE(#622700)
* Wed Nov 03 2010 Kamil Dudka - 8.6-3
- prevent sort from assertion failure in case LC_CTYPE does not match LC_TIME
(#647938)
* Tue Oct 26 2010 Kamil Dudka - 8.6-2
- improve i18n support in sort (debug-keys test is now back)
* Wed Oct 20 2010 Ondrej Vasik - 8.6-1
- new upstream release 8.6
- remove applied patches, temporarily disable sort
debug-keys test for multibyte locales (failing
because of i18n patch)
* Thu Sep 30 2010 Ondrej Vasik - 8.5-10
- various fixes for case conversion in tr(#611274)
* Wed Sep 29 2010 jkeating - 8.5-9
- Rebuilt for gcc bug 634757
* Mon Sep 20 2010 Ondrej Vasik - 8.5-8
- change assertion failure for invalid multibyte input
in sort to less confusing error message(#591352)
* Wed Sep 08 2010 Ondrej Vasik - 8.5-7
- add RELRO protection to su as well (#630017)
* Mon Sep 06 2010 Ondrej Vasik - 8.5-6
- compile su with pie again (#630017)
* Mon Aug 30 2010 Ondrej Vasik - 8.5-5
- fix double free abort in tac (#628213)
* Thu Jul 22 2010 Ondrej Vasik - 8.5-4
- Add .ear, .war, .sar , for Java jar-like archives to
dircolors (#616497)
* Fri Jul 2 2010 Dan Horák - 8.5-3
- rebuilt with the updated configuration patch
- drop the old -O1 exception for s390(x)
- updated the getgrouplist patch (Kamil Dudka)
* Tue Apr 27 2010 Ondrej Vasik - 8.5-2
- doublequote LS_COLORS in colorls.*sh scripts to speedup
shell start(#586029)
- add patch for mkstemp on sparc64(Dennis Gilmore)
- update /etc/DIR_COLORS* files
* Mon Apr 26 2010 Ondrej Vasik - 8.5-1
- new upstream release 8.5
* Thu Apr 15 2010 Ondrej Vasik - 8.4-8
- move readlink from /usr/bin to bin, keep symlink in
/usr/bin(#580682)
* Mon Mar 29 2010 Kamil Dudka - 8.4-7
- a new option df --direct
* Sat Mar 20 2010 Ondrej Vasik - 8.4-6
- run tput colors in colorls profile.d scripts only
in the interactive mode(#450424)
* Fri Feb 12 2010 Ondrej Vasik