HPTalx 1.3.1a

Rafael Ostertag

   Copyright © 2007 Rafael Ostertag
     __________________________________________________________

   Table of Contents
   1. Preamble
   2. Features
   3. Supported HP Calculators
   4. Requirements
   5. XModem Protocol
   6. ROM Upgrade
   7. Upgrading from earlier versions
   8. Building HPTalx

        8.1. Configuration
        8.2. Compilation
        8.3. Installation

   9. Getting started with HPTalx

        9.1. Device Permissions
        9.2. Setup of HPTalx
        9.3. Connecting your Calculator

   10. Using HPTalx

        10.1. The Copy Command
        10.2. The Move Command
        10.3. The Edit Command
        10.4. The Create Directory Command
        10.5. The Remove Directory Command
        10.6. The "Command" Command
        10.7. The Backup Command
        10.8. The Restore Command

   11. Contacts
   12. Credits

1. Preamble

   HPTalx Copyright© 1999, 2000 by Bruno Barberi Gnecco

   HPTalx Copyright© 2001 Bruno Barberi Gnecco and Alen Kovac

   HPTalx Copyright© 2005 Bruno Barberi Gnecco and Rafael Ostertag

   HPTalx Copyright© 2007 Bruno Barberi Gnecco and Rafael Ostertag

   Icons Copyright© 2000 Hewlett Packard and Jean-Pierre Bergamin

   This is HPTalx, a HP Calculator<->PC communications program for
   Linux, initially written by Bruno Barberi Gnecco, extended by
   Rafael Ostertag and released under the GNU Public License; see
   the COPYING file for further information. Use it at your own
   risk; the authors are not responsible for any damage from its
   use or misuse.

   You can get the latest version of HPTalx at
   http://hptalx.sourceforge.net
     __________________________________________________________

2. Features

   The main features of HPTalx are

     * Data transfer between HP Calculators and PC.
     * Backup and restore of HP Calculator memory.
     __________________________________________________________

3. Supported HP Calculators

     * HP 48
     * HP 49
     * HP 49G+
     * HP 50g
     __________________________________________________________

4. Requirements

   In order to build and run HPTalx, you need following additional
   software installed on your system:

     * GTK 2, Version 2.4 or later (http://www.gtk.org)
     * GLib 2, Version 2.4 or later (http://www.gtk.org)
     * C-Kermit, Version 8.0 or later
       (http://www.columbia.edu/kermit/ck80.html)
     * libxml, Version 2.5 or later (http://www.xmlsoft.org)

   To connect to a HP 49G+/50G via USB Serial Kernel Module, a
   Linux Kernel capable of USB Serial is needed.
     __________________________________________________________

5. XModem Protocol

   Though HPTalx 1.1.0 supports the XModem Protocol, this release
   does not. The author focused on the greatest common
   denominator, which is the Kermit Protocol for both HP 48 and HP
   49/50G Calculators.
     __________________________________________________________

6. ROM Upgrade

   HPTalx 1.1.0 supports ROM Upgrade for HP 49 Calculators.
   However, this release does not. It was tried to achieve support
   for all HP 48/49 Calculators. The HPTalx 1.1.0 ROM Upgrade
   function does not support HP 48 Calculators, so this
   functionality does not meet the criteria for this release.
     __________________________________________________________

7. Upgrading from earlier versions

   Starting with HPTalx 1.2.0, the format of the preferences file
   .hptalx has been changed. To be on the safe side, delete your
   old .hptalx file found in your Home directory prior the first
   launch of HPTalx version 1.2.0 or later.
     __________________________________________________________

8. Building HPTalx

   This is for the impatient ones. For details, see the INSTALL
   file accompanying this package.
     __________________________________________________________

8.1. Configuration

   After unpacking the tar-archive, change to the directory
   hptalx-1.3.1a. In a console, type:

        $ ./configure

   Note

        Do not type the dollar-sign, it stands for the command prompt

   If you want a different installation directory than the default
   one, append --prefix=PREFIX:

        $ ./configure --prefix=PREFIX

   Where PREFIX is meant to be the directory where the files will
   be installed.
     __________________________________________________________

8.2. Compilation

   After the configure script has finished, type:

        $ make

   This will build the binaries.
     __________________________________________________________

8.3. Installation

   When the build is done, type:

        # make install

   Remember to login as root before issuing this command, in case
   you want to install HPTalx in a different place than your Home
   Directory. After the installation took place, you will find the
   HPTalx binary hptalx installed in the directory PREFIX/bin.
     __________________________________________________________

9. Getting started with HPTalx

   Assuming the build process described above, succeeded, you are
   ready to launch HPTalx. In a console, type

        $ hptalx

   if you have installed HPTalx in a directory where the PATH
   environment variable points to, or

        $ PREFIX/bin/hptalx

   if you have configured it with the --prefix=PREFIX argument,
   whereby PREFIX is unknown to the PATH environment variable.
     __________________________________________________________

9.1. Device Permissions

   HPTalx is using either the ttyS* or ttyUSB* device entries in
   /dev depending on whether you use the serial line or USB for
   connecting your HP Calculator to the computer (see Section
   9.2). Therefore, the user using HPTalx has to have the proper
   access rights (read-write) on these device nodes. How the
   permissions are granted depends on the taste of the system
   administrator. The author recommends to either create a
   separate group for HPTalx users or putting the users requiring
   access into the group assigned to these nodes. On ancient Linux
   systems, granting access is accomplished by using chmod(1) and
   chgrp(1) on the node(s) in question. More recent Linux systems
   employ udev(7) for dynamically managing the device nodes in the
   /dev directory. Refer to the system documention for those
   systems on how to set the access permissions on the device
   node(s). Chmod(1) and chgrp(1) most likely will not work on
   those systems, since the changes will be overwritten upon next
   system reboot.
     __________________________________________________________

9.2. Setup of HPTalx

   Given HPTalx is running, select Setup from the File menu. Set
   the settings according your needs. For example, if your HP
   Calculator is wired to your COM1 port, select in the Connection
   Settings frame Serial and choose in the section Set COM port
   COM 1.

   If you are the proud owner of a HP 49g+/50g, select USB
   (ttyUSB) and choose the port your HP Calculator is connected
   to. See the README.hp49gplus file for details about those
   models.

   When you are done setting up HPTalx, press the Save button in
   the Setup Dialog to permanently store your settings. HPTalx
   then creates a file named .hptalx in your Home Directory which
   is used to store the settings. If you just press the OK button
   without first saving, your settings are only kept for the
   current session.
     __________________________________________________________

9.3. Connecting your Calculator

   First make sure you set up HPTalx as described above. Then plug
   the data cable into the HP Calculator and the communication
   port on the PC you have specified in the Setup Dialog.

   Next, you need to put the HP Calculator into Server Mode:

     * HP 48: Press Right Shift, then Right Arrow on the
       calculator.
     * HP 49/50: Press and hold Right Shift and press Right Arrow
       on the calculator.

   It is important for HP49/50 users, to put their calculator into
   Kermit Server Mode. Make sure the calculator shows the message

        Awaiting Server Cmd.

   in the display. If you read

        Xmodem Server Waiting for command

   you have started the XModem Server, which will not work with
   HPTalx 1.2.0 or later.

   Now, you are ready to connect HPTalx to your calculator. This
   is achieved by selecting the Connect menu item of the Connect.
   After the connection has been established, the content of the
   HP Calculator is displayed in the bottom half of the HPTalx
   window, hereafter referred to as HP Pane. The top half displays
   the content of the directories on your PC, which is hereafter
   referred to as PC Pane.
     __________________________________________________________

10. Using HPTalx

   If the previous steps succeeded, you can now transfer data
   between your HP Calculator and your PC.

   To transfer files from your PC to the HP Calculator, select the
   file(s) in the PC Pane and choose the menu item Transfer of the
   File menu. A window will appear and display the progress of the
   transfer. The file(s) are transfered to your HP Calculator and
   stored in the current working directory of the calculator.

   To transfer variables and directories, hereafter referred to as
   Items, to your PC, select the Item(s) in the HP Pane and choose
   the menu item Transfer of the File menu. The Item(s) will be
   stored in the current working directory on the PC.

   Generally speaking, all commands are applied on the place where
   the last selection took place, either on the PC Pane or the HP
   Pane.
     __________________________________________________________

10.1. The Copy Command

   The copy command Copy of the File copies the current selection
   to a directory of your choice. However, it does not transfer
   data between the PC and the HP Calculator. This said, you copy
   files either on the PC or Items on the HP Calculator.
     __________________________________________________________

10.2. The Move Command

   The Move command found in the File menu moves data from the PC
   to the HP Calculator and vice versa.
     __________________________________________________________

10.3. The Edit Command

   You can either edit files on the PC or Items on the HP
   Calculator by selecting the Edit menu item listed in the File
   menu.
     __________________________________________________________

10.4. The Create Directory Command

   HPTalx allows you to create new directories on both, the PC and
   the HP Calculator by using the Created Directory command of the
   Directories menu.
     __________________________________________________________

10.5. The Remove Directory Command

   Using the command Remove Directory of the Directories menu lets
   you remove entire directories including subdirectories and
   directory entries on the PC as well as on the HP Calculator. Be
   careful using this command. The command removes all files and
   subdirectories in the selected directory.
     __________________________________________________________

10.6. The "Command" Command

   You can issue RPL Commands on the HP Calculator and view their
   output by using Command of the Utilities menu.
     __________________________________________________________

10.7. The Backup Command

   This command allows you to make backups of the HP Calculator
   memory. However, it does not backup libraries and other items
   installed in the memory ports of your HP Calculator. The flags
   used to customize your HP Calculator are backed up as well, and
   can also be restored.
     __________________________________________________________

10.8. The Restore Command

   You can restore the HP Calculator memory using backups created
   with the Backup Command.

   This command replaces the content of the HP Calculator memory
   with the selected backup image, thus you are loosing all
   changes since the last backup. However, since the Backup
   Command does not backup libraries and memory ports, it cannot
   restore those.

   After a successful restore, there will be a program called
   FLAG, which does restore the calculator flags when run.
     __________________________________________________________

11. Contacts

   Please contact Rafael Ostertag <rafi@guengel.ch> for comments,
   suggestions and bugs concerning this release of HPTalx.
     __________________________________________________________

12. Credits

   Many thanks to Bruno Barberi Gnecco for writing HPTalx in the
   first place. Thanks to Michele Dunja Haering for providing a HP
   48G Calculator and Anic Studer for doing some proof read.
   Thanks also to Ricky Marshall, Joseba Garcia Etxebarria, and
   Ramiro Polla for the patches.
