# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate uuhelp_parser

Name:           rust-uuhelp_parser
Version:        0.0.23
Release:        %autorelease
Summary:        Collection of functions to parse the markdown code of help files

License:        MIT
URL:            https://crates.io/crates/uuhelp_parser
Source:         %{crates_source}
# License added in https://github.com/uutils/coreutils/commit/7383820354d497b647bd721f3b147d9700676847
Source:         https://raw.githubusercontent.com/uutils/coreutils/main/LICENSE

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A collection of functions to parse the markdown code of help files.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
# copy in license file
cp -p %{SOURCE1} .
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog