# Generated from easycompile-1.0.7.gem by gem2rpm -*- rpm-spec -*-
%global gem_name easycompile

Name: rubygem-%{gem_name}
Version: 1.0.7
Release: 1%{?dist}
Summary: This project is called easycompile.  It allows you to compile a given source archive, such as a file like "php-7.2.0.tar.xz". By default this will compile into the prefix /usr/. In order for this to work, the file at hand has to exist; in the case above, the file php-7.2.0.tar.xz has to exist locally.  For more documentation, have a look at the link called Documentation on the bottom right side of this webpage
License: GPL-2.0
URL: http://rubygems.org/gems/easycompile
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 3.2.18
BuildRequires: ruby >= 2.7.3
BuildArch: noarch

%description
This project is called easycompile.
It allows you to compile a given source archive, such as a file
like "php-7.2.0.tar.xz". By default this will compile into the
prefix /usr/. In order for this to work, the file at hand
has to exist; in the case above, the file php-7.2.0.tar.xz
has to exist locally.
For more documentation, have a look at the link called
Documentation on the bottom right side of this webpage.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/easycompile
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/doc
%{gem_instdir}/easycompile.gemspec
%{gem_instdir}/test

%changelog
* Mon Aug 23 2021 mockbuilder - 1.0.7-1
- Initial package