# Generated from forwarder19-0.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name forwarder19

Name: rubygem-%{gem_name}
Version: 0.2.1
Release: 1%{?dist}
Summary: Delegation And AOP Filters For It
License: MIT
URL: https://github.com/RobertDober/Forwarder19
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.3
# BuildRequires: rubygem(pry) >= 0.9
# BuildRequires: rubygem(pry) < 1
# BuildRequires: rubygem(rspec) >= 2.9.0
# BuildRequires: rubygem(rspec) < 2.10
BuildArch: noarch

%description
Ruby's core Forwardable gets the job done(barely) and produces most unreadable
code. 
Forwarder19 not only is more readable, much more feature rich, but also
slightly faster, meaning you can use it without performance penalty.
Additional features include: providing arguments, (partially if needed), AOP
and custom forwarding to hashes
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Mon Aug 23 2021 mockbuilder - 0.2.1-1
- Initial package