# Generated from symbiont-1.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name symbiont

Name: rubygem-%{gem_name}
Version: 1.2.0
Release: 1%{?dist}
Summary: An Endosymbiotic Facultative Semantically Clean Fluent Interface Test Framework
License: MIT
URL: https://github.com/jnyman/symbiont
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 1.8.29
BuildRequires: ruby >= 2.0
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(rubocop)
BuildArch: noarch

%description
Symbiont is a framework that allows you to describe your application in
terms of activity and page definitions. Those definitions can then be
referenced by test libraries using the DSL that Symbiont provides. The
DSL allows web elements to be proxied to a driver library.
The DSL provides a fluent interface that can be used for constructing
test execution logic. This fluent interface promotes the idea of
compressibility of your test logic, allowing for more factoring, more
reuse, and less repetition.
You can use Symbiont directly as an automated test library or you can
use it with other tools such as RSpec, Cucumber, or my own Specify tool.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.hound.yml
%exclude %{gem_instdir}/.rubocop.yml
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/symbiont.gemspec

%changelog
* Wed Aug 25 2021 mockbuilder - 1.2.0-1
- Initial package