# Generated from sync_client-0.1.8.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sync_client

Name: rubygem-%{gem_name}
Version: 0.1.8
Release: 1%{?dist}
Summary: Interface to keep attributes synchronized between services using a message queue
License: MIT
URL: http://www.sportngin.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(activerecord) > 3.0
# BuildRequires: rubygem(mongoid) >= 4.0.0.alpha
# BuildRequires: rubygem(mongoid) < 4.1
# BuildRequires: rubygem(shoulda) >= 3.5.0
# BuildRequires: rubygem(shoulda) < 3.6
# BuildRequires: rubygem(sqlite3) >= 1.3.8
# BuildRequires: rubygem(sqlite3) < 1.4
# BuildRequires: rubygem(minitest) >= 4.0
# BuildRequires: rubygem(minitest) < 5
# BuildRequires: rubygem(test-unit)
# BuildRequires: rubygem(mocha) >= 0.14.0
# BuildRequires: rubygem(mocha) < 0.15
# BuildRequires: rubygem(simplecov) > 0.7.0
# BuildRequires: rubygem(simplecov-gem-adapter) > 1.0.0
# BuildRequires: rubygem(coveralls) > 0.7.0
BuildArch: noarch

%description
SyncClient is an interface for synchronizing attributes between services.
It provides both a means of publishing changes and subscribing to them.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/app
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/test

%changelog
* Wed Aug 25 2021 mockbuilder - 0.1.8-1
- Initial package