# Generated from win32-file-0.8.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name win32-file

Name: rubygem-%{gem_name}
Version: 0.8.2
Release: 1%{?dist}
Summary: Extra or redefined methods for the File class on Windows
License: Artistic 2.0
URL: http://github.com/djberg96/win32-file
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.0
# BuildRequires: rubygem(test-unit)
# BuildRequires: rubygem(win32-security)
BuildArch: noarch

%description
The win32-file library adds several methods to the core File class which
are specific to MS Windows, such as the ability to set and retrieve file
attributes. In addition, several core methods have been redefined in
order to work properly on MS Windows, such as File.blksize. See the
README file for more details.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/CHANGES
%{gem_instdir}/MANIFEST
%{gem_instdir}/appveyor.yml
%{gem_instdir}/certs
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README
%{gem_instdir}/Rakefile
%{gem_instdir}/test
%{gem_instdir}/win32-file.gemspec

%changelog
* Wed Aug 25 2021 mockbuilder - 0.8.2-1
- Initial package