# Generated from blifutils-0.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name blifutils

Name: rubygem-%{gem_name}
Version: 0.0.2
Release: 1%{?dist}
Summary: BlifUtils is a library to handle BLIF netlists in Ruby
License: GPL-3.0
URL: http://github.com/TheotimeBollengier/blifutils
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
BlifUtils is a library to handle BLIF logic netlists in Ruby. It can read and
write files in the BLIF format, elaborate internal representations of the
netlists, analyze it, flattent modules, write the modules as VHDL entities,
and generate C++ code for fast simulation of the netlists.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/blifutils
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/share
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/examples
%{gem_instdir}/test

%changelog
* Sun Sep 12 2021 mockbuilder - 0.0.2-1
- Initial package