# Generated from canoe-0.3.3.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name canoe

Name: rubygem-%{gem_name}
Version: 0.3.3.1
Release: 1%{?dist}
Summary: a C/C++ project management and building tool
License: MIT
URL: https://github.com/Dicridon/canoe
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.7.1
BuildArch: noarch

%description
Canoe offers project management and building facilities to C/C++ projects.
If you are tired of writing Makefile, CMakeList and even SConstruct, please
let Canoe help you wipe them out.
Similar to Cargo for Rust, Canoe offers commands such as new, build, run, etc.
to help you generate a C/C++ project and build it automatically.
Different from tools like Scons and Blade, Canoe requires users to write NO
building scripts, Canoe would analyze dependencies and build like our old
friend 'make' if a few conventions over file names are followed.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/canoe
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Mon Sep 13 2021 mockbuilder - 0.3.3.1-1
- Initial package