# Generated from duckgo-1.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name duckgo

Name: rubygem-%{gem_name}
Version: 1.2.1
Release: 1%{?dist}
Summary: DuckGo is a RubyGem library and command line tool for searching with DuckDuckGo. By default, it puts out only the relevant information, but when told, it will dump all the data you could ask for. This tool aims to give access to most of the features from the official API
License: MIT
URL: https://github.com/wlib/duckgo
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
DuckGo is a RubyGem library and command line tool for searching with
DuckDuckGo. By default, it puts out only the relevant information, but when
told, it will dump all the data you could ask for. This tool aims to give
access to most of the features from the official API.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/duckgo
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.rake_tasks~
%{gem_instdir}/.vscode
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/docs
%{gem_instdir}/duckgo.gemspec

%changelog
* Mon Sep 13 2021 mockbuilder - 1.2.1-1
- Initial package