# Generated from i18n-bamboo-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name i18n-bamboo

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: Aids in development by monkey patching the Rails I18n module to always return the longest translation or localized value across all available locales
License: MIT
URL: https://github.com/tcdowney/i18n-bamboo
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9
# BuildRequires: rubygem(pry) >= 0.10
# BuildRequires: rubygem(pry) < 1
# BuildRequires: rubygem(rubocop) >= 0.27.1
# BuildRequires: rubygem(rubocop) < 0.28
# BuildRequires: rubygem(rspec) >= 3.1.0
# BuildRequires: rubygem(rspec) < 3.2
BuildArch: noarch

%description
Consider the noble bamboo.  This peculiar member of
the Poaceae family has been known to 
grow to extraordinary lengths without yielding to (mostly) any obstacles.
Not unlike bamboo, the i18n translations of a Rails app will continue to grow.
As a 
tenacious stalk of bamboo breaks through a slab of sidewalk, so too will long
translations 
break a UI.
I18n:Bamboo monkey patches the Rails I18n module and will force all calls to
I18n.translate 
(I18n.t) and I18n.localize (I18n.l) to return the longest translated or
localized value from 
all available_locales.  For obvious reasons, this gem is intended to be used
for development 
purposes only to aid in UI and internationalization/localization testing.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/i18n-bamboo.gemspec
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 0.2.0-1
- Initial package