# Generated from lopata-0.1.16.gem by gem2rpm -*- rpm-spec -*-
%global gem_name lopata

Name: rubygem-%{gem_name}
Version: 0.1.16
Release: 1%{?dist}
Summary: lopata-0.1.16
License: MIT
URL: https://github.com/avolochnev/lopata
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3.0
# BuildRequires: rubygem(cucumber) >= 3.1
# BuildRequires: rubygem(cucumber) < 4
# BuildRequires: rubygem(aruba) >= 1.0
# BuildRequires: rubygem(aruba) < 2
BuildArch: noarch

%description
Functional acceptance testing.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# cucumber
popd

%files
%dir %{gem_instdir}
%{_bindir}/lopata
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Sep 14 2021 mockbuilder - 0.1.16-1
- Initial package