# Generated from malfunction-0.3.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name malfunction

Name: rubygem-%{gem_name}
Version: 0.3.0
Release: 1%{?dist}
Summary: Define an standard way to handle the non-exceptional issues which occur in your application
License: MIT
URL: https://github.com/Freshly/malfunction
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(pry-byebug) >= 3.7.0
# BuildRequires: rubygem(simplecov) >= 0.16
# BuildRequires: rubygem(simplecov) < 1
# BuildRequires: rubygem(timecop) >= 0.9.1
# BuildRequires: rubygem(shoulda-matchers) = 4.0.1
# BuildRequires: rubygem(rspice) >= 0.21.0
# BuildRequires: rubygem(rspice) < 1.0
# BuildRequires: rubygem(spicerack-styleguide) >= 0.21.0
# BuildRequires: rubygem(spicerack-styleguide) < 1.0
BuildArch: noarch

%description
An extensible way to encapsulate the variety of BadStuff that happens in Rails
applications.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Sep 14 2021 mockbuilder - 0.3.0-1
- Initial package