# Generated from nhtsa-0.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name nhtsa

Name: rubygem-%{gem_name}
Version: 0.2.1
Release: 1%{?dist}
Summary: A simple ruby gem to access NHTSA data
License: MIT
URL: https://github.com/omundu/nhtsa
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest)
# BuildRequires: rubygem(fakeweb)
BuildArch: noarch

%description
NHTSA offers data on safety ratings, recalls, complaints, civil penalty
payments, and child safety seat inspection station locations through their
various web APIs. The main motivation for this gem is to access the NHTSA
WebAPIs and make the data available to use for any ruby application.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/NHTSA_API_Endpoints.md
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/nhtsa.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.2.1-1
- Initial package