# Generated from putty-key-1.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name putty-key

Name: rubygem-%{gem_name}
Version: 1.1.0
Release: 1%{?dist}
Summary: PuTTY private key (.ppk) library. Supports reading and writing with a refinement to OpenSSL::PKey to allow key conversion
License: MIT
URL: https://github.com/philr/putty-key
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.1.0
BuildArch: noarch

%description
PuTTY::Key is a Ruby implementation of the PuTTY private key (ppk) format,
handling reading and writing .ppk files. It includes a refinement to Ruby's
OpenSSL library to add support for converting DSA, EC and RSA private keys to
and from PuTTY private key files. This allows OpenSSH ecdsa, ssh-dss and
ssh-rsa
private keys to be converted to and from PuTTY's private key format.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/CHANGES.md
%license %{gem_instdir}/LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/putty-key.gemspec
%{gem_instdir}/test

%changelog
* Tue Sep 14 2021 mockbuilder - 1.1.0-1
- Initial package