# Generated from redparse-1.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name redparse

Name: rubygem-%{gem_name}
Version: 1.0.0
Release: 1%{?dist}
Summary: RedParse is a ruby parser written in pure ruby
License: LGPL-2.1
URL: http://github.com/coatl/redparse
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
RedParse is a ruby parser (and parser-compiler) written in pure ruby. 
Instead of YACC or ANTLR, it's parse tool is a home-brewed language. (The
tool is (at least) LALR(1)-equivalent and the 'parse language' is 
pretty nice, even in it's current form.)
My intent is to have a completely correct parser for ruby, in 100% 
ruby. And I think I've more or less succeeded. Aside from some fairly
minor quibbles (see below), RedParse can parse all known ruby 1.8 and 1.9 
constructions correctly. Input text may be encoded in ascii, binary, 
utf-8, iso-8859-1, and the euc-* family of encodings. Sjis is not yet 
supported.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/COPYING.LGPL
%{gem_instdir}/Makefile
%{gem_instdir}/Manifest.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/rplt.txt
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/History.txt
%doc %{gem_instdir}/README.txt
%{gem_instdir}/redparse.gemspec
%{gem_instdir}/test

%changelog
* Tue Sep 14 2021 mockbuilder - 1.0.0-1
- Initial package