# Generated from regexador-0.4.7.gem by gem2rpm -*- rpm-spec -*-
%global gem_name regexador

Name: rubygem-%{gem_name}
Version: 0.4.7
Release: 1%{?dist}
Summary: A mini-language to make regular expressions more readable
License: The Ruby License
URL: http://github.com/hal9000/regexador
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 2.5.0
# BuildRequires: rubygem(minitest)
BuildArch: noarch

%description
This is implemented as an "external DSL" in Ruby; that is (like SQL for
example), 
a "program" in a Ruby string is passed into some kind of parser/interpreter
method.
In this case, it is possible to use the result "as is" or to convert to an
ordinary 
Ruby regular expression.
Though this mini-language was conceived and implemented "for Ruby, using
Ruby," 
in principle there is no reason it might not also be implemented in other
languages
such as Python or Perl.
Development on this project began in mid-July 2013. As such, it is still an
immature
project. Syntax and semantics may change. Feel free to offer comments or
suggestions.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/spec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.4.7-1
- Initial package