# Generated from sequence-0.2.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sequence

Name: rubygem-%{gem_name}
Version: 0.2.4
Release: 1%{?dist}
Summary: A single api for reading and writing sequential data types
License: GPL-2.0
URL: http://github.com/coatl/sequence
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Sequence provides a unified api for access to sequential data types, like
Strings, Arrays, Files, IOs, and Enumerations. This is the external 
iterator pattern (ruby's usual iterators are internal). Each sequence 
encapsulates some data and a current position within it. Some operations 
apply to data at (or relative to) the position, others are independant 
of position. The api contains operations for moving the position, and 
reading  and writing data (with or without moving the position) forward 
or backward from the current position or anywhere.
Its perhaps most unusual feature is the ability to scan for Regexps in
not just Strings, but Files and any other type of sequence. .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/COPYING
%{gem_instdir}/GPL
%{gem_instdir}/Makefile
%{gem_instdir}/Manifest.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/History.txt
%doc %{gem_instdir}/README.txt
%{gem_instdir}/sequence.gemspec
%{gem_instdir}/test

%changelog
* Wed Sep 15 2021 mockbuilder - 0.2.4-1
- Initial package