# Generated from snipgem-0.0.9.gem by gem2rpm -*- rpm-spec -*-
%global gem_name snipgem

Name: rubygem-%{gem_name}
Version: 0.0.9
Release: 1%{?dist}
Summary: Snip is a code snipping tool to save your most interesting code for later review
License: MIT
URL: https://github.com/jgerminario/snip
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(clipboard) >= 1.0
# BuildRequires: rubygem(clipboard) < 2
BuildArch: noarch

%description
Using simple tags, you can mark snips in your code without interrupting your
workflow. At the end of the day, run 'snip' to gather your snips from all your
code for easy review. Compatible with Ruby and JavaScript. Visit the GitHub
homepage for further instructions and developer contact details.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/snip
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/config
%{gem_libdir}
%{gem_instdir}/log
%{gem_instdir}/my_snips.rb
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%{gem_instdir}/Rakefile
%{gem_instdir}/rspec
%{gem_instdir}/snip.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.0.9-1
- Initial package