# Generated from syzygies-0.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name syzygies

Name: rubygem-%{gem_name}
Version: 0.1.1
Release: 1%{?dist}
Summary: A word puzzle
License: MIT
URL: https://github.com/RomanCPodolski/syzygies
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.4
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(pry) >= 0.10.3
# BuildRequires: rubygem(pry) < 0.11
BuildArch: noarch

%description
This is a simplification of a word puzzle created by the English polymath
Lewis Caroll where the player is given a start word (e.g. WHITE) and a goal
word (e.g. GREEN).  One must conduct a chain of words, where, for adjacent
words in the chain either the first two letters of one word are the last two
letters of the next word, or the last two letters last two letters of one word
are the first two letters of the next word.  .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/syzygies
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%{gem_instdir}/wordlist.mat
%{gem_instdir}/wordsEn.txt
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/syzygies.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 0.1.1-1
- Initial package