# Generated from tracepoint-1.2.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name tracepoint

Name: rubygem-%{gem_name}
Version: 1.2.1
Release: 1%{?dist}
Summary: The perfect alternative to set_trace_func
License: BSD-2-Clause
URL: http://rubyworks.github.com/tracepoint
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(detroit)
# BuildRequires: rubygem(qed)
BuildArch: noarch

%description
A TracePoint is a Binding with the addition of event information.
Among other things, it functions very well as the join-point for
AOP. In practice it provides a better alternative to using 
set_trace_func.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.ruby
%exclude %{gem_instdir}/.yardopts
%license %{gem_instdir}/COPYING.rdoc
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/HISTORY.rdoc
%doc %{gem_instdir}/README.rdoc
%doc %{gem_instdir}/SPEC.rdoc
%{gem_instdir}/spec

%changelog
* Thu Sep 16 2021 mockbuilder - 1.2.1-1
- Initial package