# Generated from windows-pr-1.2.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name windows-pr

Name: rubygem-%{gem_name}
Version: 1.2.6
Release: 1%{?dist}
Summary: Windows functions and constants bundled via Win32::API
License: Artistic 2.0
URL: https://github.com/djberg96/windows-pr
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest) >= 5.9.0
# BuildRequires: rubygem(minitest) < 5.10
BuildArch: noarch

%description
The windows-pr library is a collection of Windows functions and constants
pre-defined for you using the windows-api library. It also autogenerates
explicit ANSI and Wide character versions of those functions, as well as
constants that can be used as methods, e.g. CloseHandle() instead of
CloseHandle.call().


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/CHANGES
%{gem_instdir}/MANIFEST
%{gem_instdir}/appveyor.yml
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/doc
%{gem_instdir}/test
%{gem_instdir}/windows-pr.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 1.2.6-1
- Initial package