# Generated from quke-0.10.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name quke

Name: rubygem-%{gem_name}
Version: 0.10.0
Release: 1%{?dist}
Summary: A gem to simplify creating acceptance tests using Cucumber
License: The Open Government Licence (OGL) Version 3
URL: https://github.com/DEFRA/quke
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.4
# BuildRequires: rubygem(byebug)
# BuildRequires: rubygem(defra_ruby_style)
# BuildRequires: rubygem(github_changelog_generator)
# BuildRequires: rubygem(rspec) >= 3.8
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(webmock) >= 3.5
# BuildRequires: rubygem(webmock) < 4
BuildArch: noarch

%description
Quke tries to simplify the process of writing and running acceptance tests by
setting up Cucumber for you. It handles the config to allow you to run your
tests in Firefox and Chrome, or the headless browser PhantomJS. It also has
out of the box setup for using Browserstack automate. This leaves you to focus
on just your features and steps.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/quke
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.10.0-1
- Initial package