# Generated from warp-dir-1.6.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name warp-dir

Name: rubygem-%{gem_name}
Version: 1.6.2
Release: 1%{?dist}
Summary: Warp-Dir (aka 'wd') replaces 'cd' and lets you instantly move between saved "warp points" and regular folders
License: MIT
URL: https://github.com/kigster/warp-dir
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel >= 1.3.6
BuildRequires: ruby >= 2.3.0
# BuildRequires: rubygem(codeclimate-test-reporter)
# BuildRequires: rubygem(rspec) >= 3.6
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rspec-its)
BuildArch: noarch

%description
Warp-Dir is compatible (and inspired by) the popular 'wd' tool available as a
ZSH module. This one is written in ruby and so it should work in any shell.
Credits for the original zsh-only tool go to
(https://github.com/mfaerevaag/wd).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/warp-dir
%{gem_instdir}/.atom-build.json
%{gem_instdir}/.codeclimate.yml
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.idea
%{gem_instdir}/.relaxed-rubocop-2.4.yml
%exclude %{gem_instdir}/.rubocop.yml
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE
%{gem_instdir}/ROADMAP.md
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/warp-dir.gemspec

%changelog
* Wed Aug 25 2021 mockbuilder - 1.6.2-1
- Initial package