# Generated from cl-1.2.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name cl

Name: rubygem-%{gem_name}
Version: 1.2.4
Release: 1%{?dist}
Summary: Object-oriented OptionParser based CLI support
License: MIT
URL: https://github.com/svenfuchs/cl
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
OptionParser based CLI support for rapid CLI development in an object-oriented
context.
This library wraps Ruby's OptionParser for parsing your options under the
hood,
so you get all the goodness that the Ruby standard library provides.
On top of that it adds a rich and powerful DSL for defining, validating, and
normalizing options, as well as automatic and gorgeous help output (modeled
after `gem --help`).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/MIT_LICENSE.md
%{gem_instdir}/NOTES.md
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/cl.gemspec
%{gem_instdir}/examples

%changelog
* Mon Sep 13 2021 mockbuilder - 1.2.4-1
- Initial package