# Generated from corundum-0.6.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name corundum

Name: rubygem-%{gem_name}
Version: 0.6.3
Release: 1%{?dist}
Summary: Tools for synthesizing rubygems
License: MIT
URL: http://nyarly.github.com/corundum/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(corundum) >= 0.0.1
# BuildRequires: rubygem(corundum) < 0.1
BuildArch: noarch

%description
A corundum is a synthetic gemstone - including synthetic rubies.  Ergo: a
tool for synthesizing gems.
Corundum starts with the outlook that gemspecs are relatively easy to work
with, and that the opinion of the RubyGems team is that they should be
treated as a configuration file, not a code file.  Furthermore, Rake is a
powerful, easy to use tool, and does admit the use of Ruby code to get the
job done.
The hard part about publishing gems is getting them into a state you'll be
proud of.  There's dozens of fiddly steps to putting together a gem fit for
public consumption, and it's very easy to get some of them wrong.
Corundum is a collection of Rake tasklibs, therefore, that will perform the
entire process of releasing gems, including QA steps up front through
packaging and releasing the gem.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/corundum-skel
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/doc
%{gem_instdir}/spec
%{gem_instdir}/spec_help

%changelog
* Mon Sep 13 2021 mockbuilder - 0.6.3-1
- Initial package