# Generated from mail-logger-0.0.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name mail-logger

Name: rubygem-%{gem_name}
Version: 0.0.4
Release: 1%{?dist}
Summary: A Rubygem to capture information about sent emails, and log them to a file all to their own!
License: MIT
URL: https://github.com/joshmcarthur/mail_logger
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(mocha) >= 0.13.3
# BuildRequires: rubygem(mocha) < 0.14
# BuildRequires: rubygem(minitest) >= 4.7.3
# BuildRequires: rubygem(minitest) < 4.8
# BuildRequires: rubygem(test-unit)
BuildArch: noarch

%description
Lodges a callback with `Mail`, capturing all of the mail being sent, and
logging it to it's own file, so you can simply look back through that file to
see what's up. .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%license %{gem_instdir}/MIT-LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/mail_logger.gemspec
%{gem_instdir}/test

%changelog
* Tue Sep 14 2021 mockbuilder - 0.0.4-1
- Initial package