# Generated from matlab_ruby-0.4.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name matlab_ruby

Name: rubygem-%{gem_name}
Version: 0.4.0
Release: 1%{?dist}
Summary: A Ruby interface to MATLAB Engine API
License: MIT
URL: https://github.com/pmatsinopoulos/matlab_ruby
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(dotenv) = 2.0.2
# BuildRequires: rubygem(rspec)
BuildArch: noarch

%description
This gem allows you to build a MATLAB Engine Application, a.k.a. a Ruby
application that embeds a MATLAB Engine. This is all done by interfacing the
MATLAB Engine API.
You can read more about the MATLAB Engine API here:
http://www.mathworks.com/help/matlab/calling-matlab-engine-from-c-c-and-fortran-programs.html.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.env.test
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-gemset
%{gem_instdir}/.ruby-version
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/matlab_ruby.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.4.0-1
- Initial package