# Generated from sept-1.5.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sept

Name: rubygem-%{gem_name}
Version: 1.5.0
Release: 1%{?dist}
Summary: HTML templates as S-Expressions
License: MIT
URL: https://github.com/bouncepaw/sept
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Write your HTML pages like Lisp code. CLI utility. Run `sept -h` for info
(html
(head
(title "Hello world")
(style ".red { color: blue }"))
(body
(p.red#cool-and-good "Handy classes and ids. Id must be last")
("p onclick='func()'" "Other attributes are expressed that way")
(p "This is %{param}"))).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/sept
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Wed Sep 15 2021 mockbuilder - 1.5.0-1
- Initial package