# Generated from short_find-1.0.8.gem by gem2rpm -*- rpm-spec -*-
%global gem_name short_find

Name: rubygem-%{gem_name}
Version: 1.0.8
Release: 1%{?dist}
Summary: Allow a user to find things by typing just enough letters to make it unique
License: MIT
URL: http://rubygems.org/gems/short_find
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
Allow a user to find things by typing just enough letters and/or numbers to
make it unique. The user can enter a string of letters. Ignoring case, spaces,
and special characters, if there is only one match, short_find will return the
item that starts with those characters. If no item is matched, or if more than
one item is matched it will give an error and allow the user to try again.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/short_find.gemspec
%{gem_instdir}/test.rb

%changelog
* Wed Sep 15 2021 mockbuilder - 1.0.8-1
- Initial package