# Generated from sugarcube-4.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sugarcube

Name: rubygem-%{gem_name}
Version: 4.0.0
Release: 1%{?dist}
Summary: Extensions for Ruby to make Rubymotion development more enjoyable, and hopefully more rubyesque!
License: MIT
URL: https://github.com/rubymotion/sugarcube
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
== Description
CocoaTouch/iOS is a *verbose* framework.  These extensions hope to make
development in rubymotion more enjoyable by tacking "UI" methods onto the
base classes (String, Fixnum, Float).  With sugarcube, you can create a
color from an integer or symbol, or create a UIFont or UIImage from a
string.
Some UI classes are opened up as well, like adding the `<<`` operator to a
`UIView` instance, instead of `view.addSubview(subview)`, you can use the more
idiomatic: `view << subview`.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/spec

%changelog
* Thu Sep 16 2021 mockbuilder - 4.0.0-1
- Initial package