# Generated from dreader-0.5.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dreader

Name: rubygem-%{gem_name}
Version: 0.5.0
Release: 1%{?dist}
Summary: Process and import data from cvs and spreadsheets
License: MIT
URL: https://ict4g.net/gitea/adolfo/dreader
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Use this gem to specify the structure of some tabular data
you want to process.  The input data can be in CSV, LibreOffice, and Excel. 
Each row
can then be passed to a block of code you define.
The gem can thus be used to check, process, import data. We use it to import
data into
Rails application, but the gem can used in any Ruby application.
The gem should be relatively easy to use, despite its name. (Dread
stands for *d*ata *r*eader).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/Changelog.org
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/dreader.gemspec
%{gem_instdir}/examples

%changelog
* Mon Aug 23 2021 mockbuilder - 0.5.0-1
- Initial package