# Generated from dailyrep-1.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dailyrep

Name: rubygem-%{gem_name}
Version: 1.0.0
Release: 1%{?dist}
Summary: Ruby app that provides values checking on particular websites and performs notification
License: MIT
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.0
BuildArch: noarch

%description
This is Ruby App collects the information you need (currency, new torrents,
etc) from various web sites.
Main features:
- local SQlite3 database to store history info
- devices notification over PushBullet service
- recent information visualization via html
- flexible configuration using json file
Currently available web site notificattions:
- http://minfin.com.ua -  UAH/USD currency
- http://micex.ru/  - RUB/USD currency
- http://dou.ua/ - new IT job opportunities
- http://kinozal.tv/ - new movies available on torrent
- http://news.yandex.ru/ - Breny Oil rate
As the example (app reloads index.html file that is shared thought Google
Drive):
www.googledrive.com/host/0Byb1mtPn4ZEAVm9zTUJQbHM2U0U.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/dailyrep
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/bin
%{gem_instdir}/config
%{gem_instdir}/db
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/dailyrep.gemspec
%{gem_instdir}/test

%changelog
* Mon Apr 18 2022 mockbuilder - 1.0.0-1
- Initial package