# Generated from filesafe-4.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name filesafe

Name: rubygem-%{gem_name}
Version: 4.0.0
Release: 1%{?dist}
Summary: Encrypt/decrypt files with a random 256-bit AES key secured by a passphrase derived master key using PBKDF2
License: MIT
URL: http://www.aarongifford.com/computers/filesafe/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
A utility script for encrypting and decrypting files using a randomly
generated 256-bit AES key and initialization vector secured using the PBKDF2
password/passphrase key derivation algorithm to secure the file key and IV.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/filesafe
%{gem_instdir}/VERSION.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.txt
%{gem_instdir}/Rakefile
%{gem_instdir}/test

%changelog
* Mon Aug 23 2021 mockbuilder - 4.0.0-1
- Initial package