# Generated from fourchette-0.1.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name fourchette

Name: rubygem-%{gem_name}
Version: 0.1.4
Release: 1%{?dist}
Summary: Your new best friend for isolated testing environments on Heroku
License: MIT
URL: https://github.com/jipiboily/fourchette
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(foreman)
# BuildRequires: rubygem(pry-byebug)
# BuildRequires: rubygem(rspec) >= 3.1.0
# BuildRequires: rubygem(rspec) < 3.2
# BuildRequires: rubygem(guard-rspec)
# BuildRequires: rubygem(terminal-notifier-guard)
# BuildRequires: rubygem(coveralls)
BuildArch: noarch

%description
Fourchette is your new best friend for having isolated testing environment. It
will help you test your GitHub PRs against a fork of one your Heroku apps. You
will have one Heroku app per PR now. Isn't that amazing? It will make testing
way easier and you won't have the (maybe) broken code from other PRs on
staging but only the code that requires testing.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/fourchette
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/Procfile
%{gem_instdir}/bin
%{gem_instdir}/config.ru
%{gem_libdir}
%{gem_instdir}/templates
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/fourchette.gemspec
%{gem_instdir}/spec

%changelog
* Mon Aug 23 2021 mockbuilder - 0.1.4-1
- Initial package