# Generated from mesa_script-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name mesa_script

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: MesaScript is a domain specific language (DSL) that allows the user to write inlists for MESA that include variables, loops, conditionals, etc. For more detailed instructions, see the readme on the github page at  https://github.com/wmwolf/MesaScript  This software requires a relatively modern installation of MESA (version > 5596). It has been tested on Ruby versions > 1.9, but there is no guarantee it will work on older (or newer!) versions. Any bugs or requests should be sent to the author, Bill Wolf, at wmwolf@physics.ucsb.edu
License: MIT
URL: https://billwolf.space/MesaScript/
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
MesaScript - a DSL for making dynamic inlists for the MESA stellar evolution
code.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/inlist2mesascript
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Aug 24 2021 mockbuilder - 0.2.0-1
- Initial package