# Generated from pinstripe-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pinstripe

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: Pinstripe makes the UI of your web application run much faster, by only updating the parts of the DOM that change when loading html content from your server. Thus removing the performance cost of a full page reload
License: MIT
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Pinstripe makes the UI of your web application run much faster, by only
updating the parts of the DOM that change when loading html content from your
server. Thus removing the performance cost of a full page reload.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.slick
%license %{gem_instdir}/LICENSE
%{gem_instdir}/package.json
%{gem_instdir}/rollup.config.js
%{gem_instdir}/web
%{gem_instdir}/yarn.lock
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/pinstripe.gemspec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.2.0-1
- Initial package