# Generated from rumrunner-0.5.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rumrunner

Name: rubygem-%{gem_name}
Version: 0.5.0
Release: 1%{?dist}
Summary: Rum Runner is a Rake-based utility for building projects with multi-stage Dockerfiles
License: MIT
URL: https://github.com/amancevice/rumrunner.git
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3.0
# BuildRequires: rubygem(pry) >= 0.12
# BuildRequires: rubygem(pry) < 1
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(simplecov) >= 0.16
# BuildRequires: rubygem(simplecov) < 1
BuildArch: noarch

%description
Rum Runner is a Rake-based utility for building multi-stage Dockerfiles.
Users can pair a multi-stage Dockerfile with a Rumfile that uses a
Rake-like DSL to customize each stage's build options and dependencies.
The `rum` executable allows users to easily invoke builds, shell-into
specific stages for debugging, and export artifacts from built containers.
Rum Runner has the following features:
* Fully compatible with Rake
* Rake-like DSL/CLI that enable simple annotation and execution of builds
* Rumfiles are completely defined in standard Ruby syntax, like Rakefiles
* Users can chain Docker build stages with prerequisites
* Artifacts can be exported from stages
* Shell tasks are automatically provided for every stage
* Stage, artifact, and shell, steps can be customized.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/rum
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Wed Aug 25 2021 mockbuilder - 0.5.0-1
- Initial package