# Generated from tea_shopper-0.3.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name tea_shopper

Name: rubygem-%{gem_name}
Version: 0.3.0
Release: 1%{?dist}
Summary: Tea Shopper helps you shop for your next great tea
License: MIT
URL: https://github.com/aparkening/tea_shopper
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
Tea Shopper is a command line interface that scrapes tea data from the web
and allows users to compare teas by name, price per ounce, and tea shop. When
the user chooses a tea, it displays specific details, such as purchase URL,
flavors, region, and description. Check out a short demonstration video. at
https://www.loom.com/share/5d3cc369d7c243d4af5e665206b39a75.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/tea_shopper
%{gem_instdir}/.DS_Store
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/PROCESS.md
%{gem_instdir}/assets
%{gem_instdir}/bin
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/tea_shopper.gemspec

%changelog
* Wed Aug 25 2021 mockbuilder - 0.3.0-1
- Initial package