# Generated from farcall-0.4.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name farcall

Name: rubygem-%{gem_name}
Version: 0.4.6
Release: 1%{?dist}
Summary: Simple, elegant and cross-platofrm RPC protocol
License: MIT
URL: https://github.com/sergeych/farcall
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(em-websocket)
# BuildRequires: rubygem(websocket-client-simple)
# BuildRequires: rubygem(boss-protocol) >= 1.4.3
BuildArch: noarch

%description
Simple and effective cross-platform RPC protocol. Can work with any
transport capable to
pass structures (dictionaries, hashes, whatever you name it). Out of the box
provides
JSON and BOSS formats over streams and sockets.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/javascript
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/farcall.gemspec
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 0.4.6-1
- Initial package