# Generated from hexapdf-0.15.9.gem by gem2rpm -*- rpm-spec -*-
%global gem_name hexapdf

Name: rubygem-%{gem_name}
Version: 0.15.9
Release: 1%{?dist}
Summary: HexaPDF - A Versatile PDF Creation and Manipulation Library For Ruby
License: AGPL-3.0 and Nonstandard
URL: https://hexapdf.gettalong.org
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.4
# BuildRequires: rubygem(kramdown) >= 2.3
# BuildRequires: rubygem(kramdown) < 3
# BuildRequires: rubygem(reline) >= 0.1
# BuildRequires: rubygem(reline) < 1
# BuildRequires: rubygem(rubocop) >= 1.0
# BuildRequires: rubygem(rubocop) < 2
BuildArch: noarch

%description
HexaPDF is a pure Ruby library with an accompanying application for working
with PDF
files.
In short, it allows creating new PDF files, manipulating existing PDF files,
merging multiple
PDF files into one, extracting meta information, text, images and files from
PDF files, securing
PDF files by encrypting them and optimizing PDF files for smaller file size or
other
criteria.
HexaPDF was designed with ease of use and performance in mind. It uses lazy
loading and lazy
computing when possible and tries to produce small PDF files by default.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/hexapdf
%license %{gem_instdir}/LICENSE
%{gem_instdir}/agpl-3.0.txt
%{gem_instdir}/bin
%{gem_instdir}/data
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/examples
%{gem_instdir}/test

%changelog
* Mon Sep 13 2021 mockbuilder - 0.15.9-1
- Initial package