# Generated from mvn2chain-1.2.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name mvn2chain

Name: rubygem-%{gem_name}
Version: 1.2.3
Release: 1%{?dist}
Summary: A command line tool that makes it easy to chain mvn2 calls
License: MIT
URL: https://github.com/henderea/mvn2chain
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.3
BuildArch: noarch

%description
A command line tool that makes it easy to chain mvn2 calls.  Register your
dependencies with the "mvn2chain dep" commands and run them with the
"mvn2chain exec" command.  See "mvn2chain help", "mvn2chain help dep", and
"mvn2chain help exec" for more information.  Some commands have aliases.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/mvn2chain
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/mvn2chain.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 1.2.3-1
- Initial package