# Generated from nice_hash-1.17.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name nice_hash

Name: rubygem-%{gem_name}
Version: 1.17.2
Release: 1%{?dist}
Summary: NiceHash creates hashes following certain patterns so your testing will be much easier. Parse and filter JSON. Perfect to be used in test data factories
License: MIT
URL: https://github.com/MarioRuiz/nice_hash
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.9.0
# BuildRequires: rubygem(rspec) >= 3.9
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
NiceHash creates hashes following certain patterns so your testing will be
much easier. Parse and filter JSON. You can easily generate all the hashes you
want following the criteria you specify. Many other features coming to Hash
class like the methods 'bury' or select_key, access the keys like methods:
my_hash.my_key.other_key. You will be able to generate thousands of different
hashes just declaring one and test easily APIs based on JSON for example.
Perfect to be used in test data factories.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.yardopts
%license %{gem_instdir}/LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Sep 14 2021 mockbuilder - 1.17.2-1
- Initial package