# Generated from pg-eyeballs-1.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pg-eyeballs

Name: rubygem-%{gem_name}
Version: 1.1.1
Release: 1%{?dist}
Summary: A Ruby gem for using the postgres explain command with Active Record
License: MIT
URL: http://github.com/bradurani/pg-eyeballs
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(database_cleaner)
BuildArch: noarch

%description
pg-eyeballs is a ruby gem that gives you detailed information about how the
SQL queries created by the active record code you write are executed by the
database. It gives you an easy, ruby friendly way to see the output of the
Postgres EXPLAIN command and integrates with the popular query analysis tool
gocmdpev.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Appraisals
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_instdir}/circle.yml
%{gem_instdir}/gemfiles
%{gem_instdir}/gocmdpev.png
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/pg-eyeballs.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 1.1.1-1
- Initial package