# Generated from rbmk-0.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rbmk

Name: rubygem-%{gem_name}
Version: 0.1.1
Release: 1%{?dist}
Summary: a trivial LDAP read-only proxy that allows you to get inside the bind and search operations
License: CC0
URL: https://github.com/exante/rbmk
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.0
BuildArch: noarch

%description
This is a rather simple Ruby LDAP server that proxies operations upstream but
at the same time provides a facility to invoke your code at certain points in
the operation runtime. This may help to accomodate for some clients that
are not smart enough to implement the logic you need themselves.
LDAP is very rigid and static in its nature and although OpenLDAP provides
some
very helpful overlays, it is far from enough.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/rbmk
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/examples

%changelog
* Tue Sep 14 2021 mockbuilder - 0.1.1-1
- Initial package