# Generated from rfix-3.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rfix

Name: rubygem-%{gem_name}
Version: 3.0.1
Release: 1%{?dist}
Summary: RuboCop CLI that only lints and auto-fixes code you committed by utilizing `git-log` and `git-diff`
License: MIT
URL: https://github.com/oleander/rfix-rb
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.6
BuildArch: noarch

%description
RuboCop CLI that only lints and auto-fixes code you committed by utilizing
`git-log` and `git-diff`. Rfix CLI makes it possible to lint (`rfix lint`) and
auto-fix (`rfix local|origin|branch`) code changes since a certain point in
history. You can auto-fix code committed since creating the current branch
(`rfix origin`) or since pushing to upstream (`rfix local`).
Includes a RuboCop formatter with syntax highlighting and build in hyperlinks
for offense documentation.
Holds the same CLI arguments as RuboCop. Run `rfix --help` for a complete list
or `rfix` for supported commands.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/rfix
%{gem_instdir}/exe
%{gem_libdir}
%{gem_instdir}/vendor
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/rfix.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 3.0.1-1
- Initial package