# Generated from roadworker-0.5.15.gem by gem2rpm -*- rpm-spec -*-
%global gem_name roadworker

Name: rubygem-%{gem_name}
Version: 0.5.15
Release: 1%{?dist}
Summary: Roadworker is a tool to manage Route53
License: MIT
URL: https://github.com/winebarrel/roadworker
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.0.0
# BuildRequires: rubygem(rspec-instafail) >= 1.0.0
# BuildRequires: rubygem(rubydns) >= 0.8.5
# BuildRequires: rubygem(rubydns) < 0.9
# BuildRequires: rubygem(coveralls)
BuildArch: noarch

%description
Roadworker is a tool to manage Route53. It defines the state of Route53 using
DSL, and updates Route53 according to DSL.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/roadwork
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Sep 14 2021 mockbuilder - 0.5.15-1
- Initial package